Supported Platforms for vCLI Commands
You cannot run the vihostupdate command against an ESXi 5.0 or later system.
You cannot run vicfg-syslog --setserver or vicfg-syslog --setport with an ESXi 5.0 or later target.
Platform Support for vCLI 5.x Commands lists platform support for the different vCLI commands.
Use esxcli software vib instead.