The upgrade to vCenter Server 5.1.x affects other software components of your datacenter.

Upgrading vCenter Server and Related Components summarizes the effect on your datacenter components.

Upgrading vCenter Server and Related Components

Product or Component

Description

vCenter Server

Verify support for the upgrade path from your current version of vCenter Server to the version that you are upgrading to. See the VMware Product Interoperability Matrix at http://www.vmware.com/resources/compatibility/sim/interop_matrix.php.

vCenter Server database

Verify that your database is supported for the vCenter Server version that you are upgrading to. Upgrade the database if necessary. See the VMware Product Interoperability Matrix at http://www.vmware.com/resources/compatibility/sim/interop_matrix.php.

Note

The version 5.1.x vCenter Server Appliance uses a PostgreSQL for the embedded database. For external databases, the vCenter Server Appliance supports only Oracle databases, in the same versions shown in the VMware Product Interoperability Matrix for the version of vCenter Server that you are upgrading to.

vSphere Client

Verify that your vSphere Client works with the vCenter Server version that you are upgrading to. For best performance and compatibility, upgrade your vSphere Client to the same version as your vCenter Server. See the VMware Product Interoperability Matrix at http://www.vmware.com/resources/compatibility/sim/interop_matrix.php.

vSphere Web Client

Verify that your vSphere Web Client works with the vCenter Server version that you are upgrading to. For best performance and compatibility, upgrade your vSphere Web Client to the same version as your vCenter Server. See the VMware Product Interoperability Matrix at http://www.vmware.com/resources/compatibility/sim/interop_matrix.php.

ESX and ESXi hosts

Verify that your ESX or ESXi host works with the vCenter Server version that you are upgrading to.Upgrade if necessary. See the VMware Product Interoperability Matrix at http://www.vmware.com/resources/compatibility/sim/interop_matrix.php.

VMFS2 volumes

Supported as read-only (deprecated).

VMFS3 volumes

No change.

VMDK2 virtual disk

Not supported with vCenter vCenter Server 5.1.x.

VMDK3 virtual disk

Not supported with vCenter Server 5.1.x.

ESX MUI

No change.

Virtual machines

Upgrade options depend on your current version. See Upgrading Virtual Machines.

VMware Tools

Upgrade options depend on your current version. See the information about upgrading VMware Tools in Upgrading Virtual Machines.

Auto Deploy 5.0.x

Upgrade to Auto Deploy 5.1.x and vCenter Server 5.1.x. You must upgrade Auto Deploy 5.0.x to version 5.1.x for use with vCenter Server 5.1.x

Auto Deploy 5.1

To ensure compatibility and best performance, upgrade to Auto Deploy 5.1.x when you upgrade to vCenter Server 5.1.x.