VMware supports in-place upgrades on 64-bit systems from vCenter Server 4.x and vCenter Server 5.0 to vCenter Server 5.0.x.

You can upgrade VirtualCenter 2.5 Update 6 or later and vCenter Server 4.0.x to vCenter Server 5.0.x by installing vCenter Server 5.0.x on a new machine and migrating the existing database. This upgrade method makes it possible to upgrade from a 32-bit system to a 64-bit system. Alternatively, if the VirtualCenter or vCenter Server database is on a remote machine, you can upgrade the database.

vCenter Server 5.0.x can manage ESX 3.5.x/ESXi 3.5.x hosts in the same cluster with ESX 4.x/ESXi 4.x hosts.

Note

You cannot upgrade a vCenter Server 4.x instance that is running on Windows XP Professional x64 Edition to vCenter Server 5.0, because vCenter Server 5.0.x does not support Windows XP Professional x64.