A vCenter Server upgrade fails if you restore a Microsoft SQL 2000 database backup to the vCenter Server database.

When the failure occurs, the following error message appears: DBuser entered doesn't have the required permissions to install and configure vCenter Server with the selected DB.

This problem can occur when you upgrade to vCenter Server from VirtualCenter 2.x. VirtualCenter 2.x supports SQL 2000, which VMware does not support for vCenter Server 5.0. When you restore a backup from SQL Server 2000 on SQL Server 2005, the restored database is set to compatibility level 80, which is compatible with SQL Server 2000. The minimum supported compatibility level for vCenter Server 5.0 databases is 90, which is compatible with SQL Server 2005.

Before you upgrade to vCenter Server, change the compatibility level to 90, for compatibility with SQL Server 2005, or to 100, for compatibility with SQL Server 2008.

ALTER DATABASE AdventureWorks SET SINGLE_USER;
GO 
EXEC sp_dbcmptlevel AdventureWorks, 90;
GO
ALTER DATABASE AdventureWorks SET MULTI_USER;
GO