When you use the vendor provider functionality, certain requirements and considerations apply.

The vendor provider functionality is implemented as an extension to the VMware vCenter Storage Monitoring Service (SMS). Because the SMS is a part of the vCenter Server, the vendor provider functionality does not need special installation or enablement on the vCenter Server side.

To use vendor providers, follow these requirements:

vCenter Server version 5.0 or later.

ESX/ESXi hosts version 4.0 or later.

Storage arrays that support Storage APIs - Storage Awareness plug-ins. The vendor provider component must be installed on the storage side. See the vSphere Compatibility Guide or check with your storage vendor.

Note

Fibre Channel over Ethernet (FCoE) does not support vendor providers.

The following considerations exist when you use the vendor providers:

Both block storage and file system storage devices can use vendor providers.

Vendor providers can run anywhere, except the vCenter Server.

Multiple vCenter Servers can simultaneously connect to a single instance of a vendor provider.

A single vCenter Server can simultaneously connect to multiple different vendor providers. It is possible to have a different vendor provider for each type of physical storage device available to your host.