The hardware acceleration functionality works only if you use an appropriate host and storage array combination.

Hardware Acceleration Storage Requirements

ESXi

Block Storage Devices

NAS Devices

ESX/ESXi version 4.1

Support block storage plug-ins for array integration (VAAI)

Not supported

ESXi version 5.0

Support T10 SCSI standard or block storage plug-ins for array integration (VAAI)

Support NAS plug-ins for array integration

Note

If your SAN or NAS storage fabric uses an intermediate appliance in front of a storage system that supports hardware acceleration, the intermediate appliance must also support hardware acceleration and be properly certified. The intermediate appliance might be a storage virtualization appliance, I/O acceleration appliance, encryption appliance, and so on.