Installing vCLI on Linux Systems with Internet Access
Before you can install the vCLI package on a Linux system with Internet access, that system must meet following prerequisites.
Internet access. You must have Internet access when you run the installer because the installer uses CPAN to install prerequisite Perl modules.
Development Tools and Libraries. You must install the Development Tools and Libraries for the Linux platform that you are working with before you install vCLI and prerequisite Perl modules.
Proxy settings. If your system is using a proxy for Internet access, you must set the http:// and ftp:// proxies, as follows:
export http_proxy=<proxy_server>:port
export ftp_proxy=<proxy_server>:port
Installing Required Prerequisite Software for Linux Systems with Internet Access
If required prerequisite software is not installed, the installer stops and requests that you install it. Installation of prerequisite software depends on the platform that you are using.
Install prerequisites using yum, the RHEL package installer (recommended), or from the installation DVD. For example:
SLES 10, 64 bit. yast -i openssl-devel libxml2-devel-32bit e2fsprogs-devel-32bit
SLES 10, 32 bit. yast -i openssl-devel libxml2-devel e2fsprogs-devel
SLES 11 64 bit. yast -i openssl-devel libuuid-devel libuuid-devel-32bit
SLES 11 32 bit. yast -i openssl-devel libuuid-devel
32 bit. sudo apt-get install build-essential gcc uuid uuid-dev perl libssl-dev perl-doc liburi-perl libxml-libxml-perl libcrypt-ssleay-perl
64 bit. sudo apt-get install ia32-libs build-essential gcc uuid uuid-dev perl libssl-dev perl-doc liburi-perl libxml-libxml-perl libcrypt-ssleay-perl
Installing the vCLI Package on a Linux System with Internet Access
Install the vCLI package and run a command to verify installation was successful.
To install vCLI
1
2
tar –zxvf VMware-vSphere-CLI-5.X.X-XXXXX.i386.tar.gz
A vmware-vsphere-vcli-distrib directory is created.
3
(Optional) If your server uses a proxy to access the Internet, and if your http:// and ftp:// proxy were not set when you installed prerequisite software, set them now.
export http_proxy=<proxy_server>:port
export ftp_proxy=<proxy_server>:port
4
sudo vmware-vsphere-cli-distrib/vmware-install.pl
5
The installer connects to CPAN and installs prerequisite software. Establishing a connection might take a long time.
6
The installer connects to CPAN and installs prerequisite software. Establishing a connection might take a long time..
7
A complete installation process has the following result:
If you accepted the defaults during installation, you can find the installed software in the following locations:
vCLI scripts/usr/bin
vSphere SDK for Perl utility applications/usr/lib/vmware-vcli/apps
vSphere SDK for Perl sample scripts/usr/share/doc/vmware-vcli/samples
See the vSphere SDK for Perl documentation for a reference to all utility applications. After you install vCLI, you can test the installation by running a vCLI command or vSphere SDK for Perl utility application from the command prompt.