You can use the VMware vSphere PowerCLI 5.0.1 components to manage all supported vSphere and vCloud environments.

vSphere PowerCLI 5.0.1 is compatible with the following vSphere environments:

VMware ESXi 5.0

vCenter Server 5.0

VMware ESX 4.1 Update 2 and vCenter Server 4.1 Update 2

VMware ESXi 4.1 Update 2

VMware ESX 4.0 Update 4 and vCenter Server 4.0 Update 4

VMware ESX 4.0i Update 4

VMware ESX 3.5 Update 5

VMware ESXi 3.5 Update 5

VMware VirtualCenter 2.5 Update 6

vCloud Director PowerCLI 1.5 is compatible with VMware vCloud Director 1.5.