You might have problems if you are using a version of Firefox that does not support running vSphere Web Access.

Firefox does not open vSphere Web Access.

Several causes might trigger this problem.

Your Mozilla Firefox version does not support GTK.

Your Mozilla Firefox browser installation was included in your Linux distribution. Some distributions package Firefox incorrectly and do not work with vSphere Web Access.

Download and install the latest version of Firefox from the Mozilla Web site.