You are unable to install or upgrade the vCloud Hybrid Service plug-in in vSphere Web Client 5.5 Update 1 or later.

In vSphere Web Client Update 1 or later, when you try to install or upgrade the plug-in, you get the error "Installation failed. Try installing again."

This problem occurs if your vCenter Server is unable to connect to the Internet or unable to connect to the My VMware REST API endpoints from which the vCloud Hybrid Service plug-in installer downloads the plug-in. Your vCenter Server must be set up in a way that it can connect to the Internet.

1

Verify that your vCenter Server can connect to the Internet.

2

Verify that the vCenter Server can reach the host svcgw.vmware.com.

For example: ping svcgw.vmware.com

3

Check the number of hops in the connection. Use any utility of your choice.

For example: traceroute svcgw.vmware.com

4

Check if any firewalls are blocking the connection.

5

After resolving the above issues, try installing again.

6

If you still get an error, use any REST client to check if your vCenter Server can reach the My VMware REST API endpoints.

You should be able to reach the URL https://svcgw.vmware.com/prod/services/DownloadUrlService/lookupProduct. The following request should get a similar response.

Request

<ProductsLookupRequest xmlns="productlookup.generic.com/types">

       <RequestId>1001</RequestId>

       <RequestTimeStamp>2002-05-30T09:00:00</RequestTimeStamp>

       <ProductVersion>5.5.0.0</ProductVersion>

       <ProductName>vcenter-server</ProductName>

       <CompatibleProductVersion></CompatibleProductVersion>

       <CompatibleProductName>hybrid-cloud-plugin-1</CompatibleProductName>

       <LastSyncDate>2002-05-29T09:00:00</LastSyncDate>

</ProductsLookupRequest>

Response

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>

<productLookupResponse

   xmlns="productlookup.generic.com/types">

   <ResponseId>1001</ResponseId>

   <ResponseTimeStamp>2014-05-04T22:47:54.189-07:00</ResponseTimeStamp>

   <ProductVersion>5.5.0.0</ProductVersion>

   <ProductName>vcenter-server</ProductName>

   <CompatibleProductsList>

       <CompatibleProduct>

           <filename>vchsplugin-1628768.zip</filename>

           <name>hybrid-cloud-plugin-1</name>

           <sha1Checksum>5a3c499f65985ebf07ba32d9928c0cda01a46a1b</sha1Checksum>

           <version>1.0.1.0</version>

       </CompatibleProduct>

   </CompatibleProductsList>

</productLookupResponse>