Sandbox Compatibility between ThinApp 4.x and 5.x
Sandbox of Applications built using ThinApp4.x areis not compatible with ThinApp5.0 Sandboxes. If the application runtime is upgraded from ThinApp4.x to ThinApp5.0 (by using Relink, Rebuilding the package or any other upgrade mechanism), the old sandbox needs to be removed before using the upgraded application.
However, If the user requires to preserve the settings made to existing ThinApp application, SBMerge.exe tool can be utilized to merge the sandbox to the package itself. This package can be rebuilt using ThinApp5.0 to upgrade the Application Runtime. For information about the sbmerge.exe utility, see Updating Applications with Runtime Changes