Install the Log Insight Linux Agent RPM package by using the system terminal or the GUI.

Log in as root or use sudo to run console commands.

The Log Insight Linux Agent needs access to syslog and networking services to function. Install and run Log Insight Linux Agent on runlevels 3 and 5. If you want the Log Insight Linux Agent to work under other runlevels, configure the system appropriately.

1

Open a console and run the rpm -i package_name command to install the Log Insight Linux Agent. Replace package_name with the appropriate version. For example,

 rpm -i VMware-Log-Insight-Agent-VERSION-BUILD_NUMBER.rpm 	  
Note

To set the target vRealize Log Insight server during installation run the following command replacing hostname with the IP address or hostname of the vRealize Log Insight server.

sudo SERVERHOST=hostname rpm -i VMware-Log-Insight-Agent-VERSION-BUILD_NUMBER.rpm
2

(Optional) To update the Log Insight Linux Agent run the following command.

rpm -Uhv VMware-Log-Insight-Agent-VERSION-BUILD_NUMBER.rpm

Note

You can run other RPM commands such as -h, --hash, --version,--allfiles and so on during the installation, update or uninstallation of the Log Insight Linux Agent RPM package, but they are not officially supported.

3

(Optional) To run the Log Insight Linux Agent as a non root user run the following command.

sudo LIAGENTUSER=liagent rpm -i VMware-Log-Insight-Agent-VERSION-BUILD_NUMBER.rpm

If the specified user does not exist, the Log Insight Linux Agent creates the user account during the installation. The created account is not deleted after uninstallation. If you install the Log Insight Linux Agent with LIAGENTUSER=non_root_user parameter and try to upgrade with LIAGENTUSER=non_root_user2, it will cause a conflict and you will see warnings because non_root_user2 user does not have the permissions of the user non_root_user.

4

(Optional) You can install or update the Log Insight Linux Agentby using the GUI. Double click on the appropriate version of the RPM package.

Note

Upgrade of older versions of the Log Insight Linux Agent from 2.5 TP1, 2.5 TP2 or 2.5 TP3 to newer versions is not supported. You must uninstall the older RPM packages.

5

(Optional) Verify the installed version by running rpm -qa | grep Log-Insight-Agent