Before you begin the VMware Integrated OpenStack deployment tasks, the software components must meet all of the version prerequisites for vSphere, ESXi hosts. In a typical deployment, you require at least three ESXi hosts for the OpenStack management cluster and at least one ESXi host for the OpenStack compute cluster.

Requirement

Description

vSphere version

Supported versions:

vSphere 6 Update 1 Enterprise Plus

vSphere 6 Enterprise Plus

vSphere 5.5 Update 3 Enterprise Plus

vSphere 5.5 Update 2 Enterprise Plus

ESXi hosts

Supported versions:

Version 6.0 Update 1

Version 6.0

Version 5.5 Update 3

Version 5.5 Update 2

Eight or more logical processors on each host.

The vCenter and all ESXi hosts intended for the VMware Integrated OpenStack deployment must use the same Network Time Protocol (NTP) server. For details about configuring NTP on ESX servers, see the VMware knowledge base article at http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003063.