Before you begin the VMware Integrated OpenStack deployment tasks, the software components must meet all of the version prerequisites for vSphere, ESXi hosts, and the NSX product. In a typical deployment, you require at least three ESXi hosts for the OpenStack management cluster and at least one ESXi host for the OpenStack compute cluster.

Requirement

Description

vSphere version

Supported versions:

See the VMware Product Interoperability Matrix at http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php for the supported versions.

ESXi hosts

Supported versions:

See the VMware Product Interoperability Matrix at http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php for the supported versions.

Eight or more logical processors on each host.

The vCenter and all ESXi hosts intended for the VMware Integrated OpenStack deployment must use the same Network Time Protocol (NTP) server. For details about configuring NTP on ESX servers, see the VMware knowledge base article at http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1003063 and the vSphere documentation at http://pubs.vmware.com/vsphere-55/index.jsp?topic=%2Fcom.vmware.vsphere.vcenterhost.doc%2FGUID-8756D419-A878-4AE0-9183-C6D5A91A8FB1.html.

NSX

See the VMware Product Interoperability Matrix at http://partnerweb.vmware.com/comp_guide2/sim/interop_matrix.php for the preferred version.