Upgrading your existing vCenter Hyperic installation to the most recent version provides you with access to the latest features and enhancements. If you have been using a database other than vPostgreSQL, you must migrate it to continue access to its data.

The installer installs a new version of vCenter Hyperic, configuring the new server instance based on the configuration information from your previous server installation configuration files.

If you use the vCenter Hyperic internal database, the installer creates a new database instance that contains the data from the existing instance. The new instance has an updated schema. The PostgreSQL server is not upgraded to a new version.

If you use an external database, the installer updates the existing instance.

You upgrade the vCenter Hyperic server on Windows platforms using the upgrade option of the vCenter Hyperic installer.

You upgrade the vCenter Hyperic server on Unix-based platforms using the upgrade option of the vCenter Hyperic installer.

You can upgrade the version of the vCenter Hyperic vApp to the latest version.

To use the latest version ofvCenter Hyperic you must use a vPostgreSQL database. If you have an earlier version of vCenter Hyperic that supported other database types, you can migrate the database to vPostgreSQL after you have installed the upgraded vCenter Hyperic server.