You cannot upgrade an older version of the vCloud Application Director appliance to the latest version.

You must create and deploy a new virtual appliance in either vCloud Director 5.1.2 or 5.5 or vSphere vCenter 5.0, 5.1, or 5.5, and install the latest version of vCloud Application Director. For more information about licensing requirements, see vCloud Application Director System Requirements.

You can import and export packages created in vCloud Application Director 5.0 and 5.2 to 6.0. You can also import and export packages between different vCloud Application Director 6.0 appliances. See Using the CLI Import and Export Functions.