NSX-vRO Plugin 1.0.4 Release Notes

NSX-vRO Plugin 1.0.4 | 25 August 2016 | Build 4233593

What’s in the Release Notes

What’s New

The NSX-vRO plugin 1.0.4 now ships with Java 1.8. The NSX-vRO plugin 1.0.4 further addresses issues related to concurrency, in addition to few other bug fixes involving descriptions to be seen in vRealize Orchestrator UI for Security policies and tags. Also, support for handling scenarios where the same NSX manager has NSX Edges of different versions installed is included. The NSX-vRO plugin 1.0.4 also introduces a new workflow for assigning multiple security policies to a security group. This is a release supporting NSX version 6.2.x.

System Requirements and Installation

System Requirements

  • Verify that you are running a vRealize Orchestrator instance.
  • Verify that you have credentials for an account with permission to install vRealize Orchestrator plugins and to authenticate through vCenter Single Sign-On.
  • Verify that you have installed vRealize Orchestrator Client and that you can log in with Administrator credentials.

Installation Procedure

  • Download the plug-in file to a location accessible from the vRealize Orchestrator server. The plug-in installer filename is o11nplugin-nsx-1.0.4.vmoapp. The plug-in installation file for networking and security is available from the VMware product download site at vmware.com/web/vmware/downloads under the VMware NSX link.
  • Open a browser and launch the vRealize Orchestrator Configuration interface. An example of the URL format is https://orchestrator_server.com:8283.
  • Click the Plug-ins item in the left pane and scroll down to the Install new plug-in section.
  • In the Plug-in file text box, browse to the plug-in installer file and click Upload and install. The file must be in .vmoapp format.
  • Accept the license agreement in the Install a Plugin pane, when prompted.
  • Go to the Plug-ins section and confirm that NSX 1.0.4.4233593 is listed, where 4233593 is the build number.
  • Restart the vRealize Orchestrator Server service.
  • Relaunch the vRealize Orchestrator Configuration interface.
  • Click the Plug-ins item and verify that the status changed to Installation OK.

Upgrade Notes

If you have a vRealize Orchestrator 5.5.2, 6.0.x, or 7.0 instance running with the vRO - NSX plugin 1.0.1, 1.0.2 or 1.0.3 installed, and you have credentials for an account with permission to install vRealize Orchestrator plugins and to authenticate through vCenter Single Sign-On, then you can upgrade to the new vRO - NSX plugin as shown below:

  • Download the plug-in file to a location accessible from the vRealize Orchestrator server. The plug-in installer filename is o11nplugin-nsx-1.0.4.vmoapp. The plug-in installation file for networking and security is available from the VMware product download site at vmware.com/web/vmware/downloads under the VMware NSX link.
  • Open a browser and launch the vRealize Orchestrator Configuration interface. An example of the URL format is https://orchestrator_server.com:8283.
  • Go to the Plug-ins section and confirm that NSX 1.0.3.3293982 is listed, where 3293982 is the build number for vRO - NSX plugin 1.0.3.
  • In the Plug-in file text box, browse to the plug-in installer file and click Upload and install. The file must be in .vmoapp format.
  • Accept the license agreement in the Install a Plugin pane, when prompted.
  • The status “NSX (1.0.4 build 4233593) Plug-in with same name was already installed (1.0.3 build 3293982): overwriting existing plug-in,” will be displayed, which confirms that the vRO - NSX plugin has been upgraded.
  • Restart the vRealize Orchestrator Server service.
  • Relaunch the vRealize Orchestrator Configuration interface.
  • Click the Plug-ins item and verify that the status changed to Installation OK.

Known Issues

  • None.

Resolved Issues

  • 1471222: NSX Data Collection: Security Policy description is missing.
  • 1472789: NSX plugin is unable to delete network after deleting the NSX Edge that was connected to it.
  • 1474860: Support assigning multiple security policies to a security group.
  • 1513668: vCO NSX plugin does not support concurrent vco.workflow.id.add.load.balancer workflows on the same edge device.
  • 1529245: NSX Plugin: Error adding machine to existing load balancer with NSX 6.2.
  • 1542960: For VCNS endpoints, vCO NSX plugin workflow vco.workflow.id.add.load.balancer does not set load balancer pool protocol in its output.
  • 1544630: vRA (VCNS) Edge is in Missing state (Managed machines page) right after deployment provision succeeds and data collection runs.
  • 1580580: Logical Switch deletion workflow failures with VRA plugin in NSX 6.2.1.
  • 1581869: NSX Data Collection failing in VRA 7.0 GA.
  • 1644773: o11n-nsx-plugin is using old version of spring.
  • 1669726: After upgrade the NSX Plugin to 1.0.3 the vRealize Orchestrator The NSX Edges: Page-0 shows as Error in Plug-in..

Document Revision History

25 August 2016: First edition for NSX-vRO Plugin 1.0.4