NSX Data Security does not support a direct upgrade. You must uninstall the current Data Security software before upgrading to NSX Manager. After NSX Manager is upgraded, you can install NSX Data Security version 6.0. If you upgraded to NSX Manager without uninstalling Data Security, you must do so using a REST call.

Pre-NSX Data Security policies and violation reports are carried over to the vSphere Web Client, but you can run a Data Security scan only after installing NSX Data Security version 6.0.

For information on installing Data Security, see Install Data Security.