SupportedVersionsType

Element:
SupportedVersions
Type:
SupportedVersionsType
Namespace:
http://www.vmware.com/vr/v6.0
Description:
HCS server supported versions type.
Since:
1.0
Schema:
hcs.xsd
Media type(s):
application/vnd.vmware.hcs.supportedVersionsType+xml
Extends:
ResourceType
XML Representation:
<SupportedVersions xmlns="http://www.vmware.com/vr/v6.0" xmlns:vcloud_v1.5="http://www.vmware.com/vcloud/v1.5" href="xs:anyURI" type="xs:string">
    <vcloud_v1.5:VCloudExtension required="xs:boolean"/>
    <vcloud_v1.5:Link href="xs:anyURI" id="xs:string" type="xs:string" name="xs:string"
            rel="xs:string">
        <vcloud_v1.5:VCloudExtension required="xs:boolean"/>
    </vcloud_v1.5:Link>
    <SupportedVersions>
        <vcloud_v1.5:VCloudExtension required="xs:boolean"/>
        <SupportedVersions> xs:string </SupportedVersions>
    </SupportedVersions>
</SupportedVersions>

Attributes

Attribute Type Required Modifiable Since Deprecated Description
href anyURI No always 1.0 The URI of the entity.
type string No always 1.0 The MIME type of the entity.

Elements

Element Type Required Modifiable Since Deprecated Description
Link LinkType No none 1.0 A reference to an entity or operation associated with this object.
SupportedVersions VersionInfoType No 1.0 A set of supported versions.
VCloudExtension VCloudExtensionType No always 1.0 An optional extension element that can contain an arbitrary number of elements and attributes. Not related to extension services.

Operations

CRUD Operation Description Since Deprecated
read GET /vr/versions This API is not annotated with {@link com.vmware.hcs.rest.annotations.VrSupported} because HCS client of every version must be able to call it without error.