Verify that all components meet basic compatibility requirements before upgrading vCenter Server.

Verify that your system meets the hardware and software requirements. See vCenter Server for Windows Requirements and System Requirements for the New vCenter Server Appliance and Platform Services Controller Appliance

If you have solutions or plug-ins, check the VMware Product Interoperability Matrix. See http://www.vmware.com/resources/compatibility/sim/interop_matrix.php

1

The installation path of the previous version of vCenter Server must be compatible with the installation requirements for Microsoft Active Directory Application Mode (ADAM/AD LDS).

The installation path must contain only ASCII characters. Extended ASCII and non-ASCII characters are unsupported.

If your previous version of vCenter Server does not meet this requirement, you must perform a fresh installation of vCenter Server.

2

Verify that the vCenter Server system is not an Active Directory primary or backup domain controller.

3

Update any ESXi 5.0 or ESXi 5.1 hosts to version 5.5.

4

If you have ESXi 5.0 or ESXi 5.1 hosts that you choose not to upgrade, you must remove them from the vCenter Server inventory.