For vSphere deployments, VMware provides operating system specific packages (OSPs) as a packaging and distribution mechanism for VMware Tools. These VMware Tools OSPs are packaged using native package formats and standards such as rpm and deb.

Note

If you already have open-vm-tools installed, it is recommended that you do not create OSPs for Linux distributions. For information about compatibility support for guest operating system, see the VMware Compatibility Guide.

Using OSPs provides the following benefits:

You can use the native update mechanisms of the guest operating system to download, install, and manage VMware Tools.

You can upgrade to the latest version of VMware Tools without having to upgrade to the latest version of vSphere.

Because VMware Tools OSPs follow the best practices and standards of the specific Linux operating system, OSPs use standard mechanisms for determining dependencies among packages. These mechanisms allow you to audit the packages on virtual machines with or without graphics components.

You can use standard operating system tools to examine OSPs during VMware Tools installation. This process allows you to easily determine which components to install and to verify the validity of the packaging.

Important

Use OSPs if you want to use native update mechanisms, rather than vCenter Server, to manage updates for VMware Tools. If you use an OSP, the VMware Tools status is Guest Managed on the virtual machine Summary tab. The status Guest Managed means that you cannot use the vCenter Server to manage VMware Tools and you cannot use vSphere Update Manager to upgrade VMware Tools.

For more information, go to the VMware Operating System Specific Packages Web site, at http://www.vmware.com/download/packages.html.