Virtual machine users and vCenter Server administrators must use the vSphere Client 6.0 to connect to vCenter Server 6.0 or to connect directly to ESXi 6.0 hosts.

You can install the VI Client 2.5, the vSphere Client 4.x, the vSphere Client 5.x, and the vSphere Client 6.0 on the same machine. After you upgrade vCenter Server, upgrade the vSphere Client to the same version to avoid compatibility problems that might interfere with the operation of the vSphere Client.

The vSphere Client upgrade operation requires no downtime. You do not need to power off virtual machines or clients.

Verify that you have the vCenter Server installer or the vSphere Client installer.

Verify that you are a member of the Administrators group on the system.

Verify that the system has an Internet connection.

1

(Optional) Use Add/Remove Programs from the Windows Control Panel to remove any previous vCenter Server client.

You do not need to remove earlier versions of vCenter Server clients. These versions are useful if you must connect to legacy hosts.

2

Run the vSphere Client installer.

Start the vCenter Server installer. In the software installer directory, double-click the autorun.exe file and select vSphere Client .

If you downloaded the vSphere Client, double-click the VMware-viclient-build number.exe file.

After you install the vSphere Client 6.0, you can connect to an ESXi host by using the domain name or IP address of the host and the user name and password of a user on that machine.

Use the vSphere Client to connect directly to an ESXi host by using your user name and password.

If the vSphere Client displays security alerts and exceptions when you log in or perform some operations, , your Internet Explorer (IE) security settings might be set to High. Examples of security settings that are set to High include opening performance charts or viewing the Summary tab. If your IE security settings are set to High, enable the Allow scripting of Internet Explorer web browser control setting in IE.