The VMware vCenter Server Appliance can be upgraded only on hosts that are running ESXi version 5.0 or later.

You can upgrade the vCenter Server Appliance only by using the Client Integration Plug-In, which is an HTML installer for Windows that you can use to connect directly to an ESXi 5.0.x, ESXi 5.1.x, ESXi 5.5.x, or ESXi 6.0 host and deploy the vCenter Server Appliance on the host.

Important

You cannot deploy the vCenter Server Appliance by using the vSphere Client or the vSphere Web Client. During the deployment of the vCenter Server Appliance you must provide various inputs, such as operating system and vCenter Single Sign-On passwords. If you try to deploy the appliance by using the vSphere Client or the vSphere Web Client, you are not prompted to provide such inputs and the deployment fails.