vCLI is supported on Red Hat Enterprise Linux (RHEL) versions that are listed in the Release Notes. On RHEL, the vSphere SDK for Perl installer prompts you to choose whether you want to install required Perl modules from the installation package or from CPAN.

Follow these steps to install the software.


Install prerequisite software. See Installing Required Prerequisite Software for Red Hat Enterprise Linux.


When prompted, choose one of the following options.

Install additional prerequisite software from the installation package. See Installing the vCLI Package on RHEL with No Internet Access.

Install additional prerequisite software from CPAN. See Install the vCLI Package on a Linux System with Internet Access.