PowerCLI is compatible with multiple versions of Windows PowerShell.

For a list of PowerShell versions with which VMware PowerCLI 6.5.4 is compatible, see Compatibility Matrixes for VMware PowerCLI 6.5.4.