Use the vSphere Web Client to connect to vCenter Server systems and manage vSphere inventory objects.

Use of the vSphere Web Client requires a supported Web browser. VMware has tested and supports the following browser versions:

Microsoft Internet Explorer 7, 8, 9 and 10 (64-bit only)

Mozilla Firefox 17

Google Chrome 23

vSphere Web Client might also work with higher versions of these browsers.

The vSphere Web Client also requires Adobe Flash Player version 10.1.0 or later to be installed in your browser.