The upgrade to vCenter Server impacts other software components of your datacenter.

Upgrading vCenter Server Components summarizes the impact on your datacenter components.

Upgrading vCenter Server Components

Product

Component

Description

vCenter Server

Note

See the release notes of the specific vCenter Server release to which you are upgrading for details on supported upgrade paths.

VI Client 1.x

Not supported

VirtualCenter Server 1.x

Not supported

vSphere Client 4.0

Upgrade

VirtualCenter Server 2.0

Not supported

VirtualCenter Server 2.5

Upgrade by using the data migration tool to upgrade to vCenter Server 4.1 on a different machine.

Note

See the release notes of the specific vCenter Server release to which you are upgrading for details on supported upgrade paths.

Starting with vCenter Server 4.1 Update 1, you cannot upgrade vCenter Server from releases prior to VirtualCenter Server 2.5 Update 6.

vCenter Server 4.0

Upgrade in place if it is installed on a 64-bit system. If it is installed on a 32-bit system, upgrade by using the data migration tool to upgrade to vCenter Server 4.1 on a different machine.

Note

See the release notes of the specific vCenter Server release to which you are upgrading for details on supported upgrade paths.

vCenter Server 4.1

Install

vSphere Client 4.1

Install

Oracle database

Verify that your database is supported. Upgrade if necessary.

Oracle 9i is no longer supported.

SQL database

Verify that your database is supported. Upgrade if necessary.

Microsoft SQL Server 2000 is no longer supported.

Linked Mode

Cannot join a Linked Mode group during the upgrade procedure. Join after the upgrade to vCenter Server is complete.

License server

License server

To manage ESX 3.x/ESXi 3.5 hosts, verify that the vCenter Server system is configured to use a license server. Install a license server if necessary.

ESX

ESX 2.5 host

Not supported with vCenter Server 4.1. Supported with vCenter Server 4.0, but cannot add the hosts to clusters.

VMFS2 volumes

Supported as read-only (deprecated)

VM2 virtual machines

Upgrade (optional)

VMDK2 virtual disk

Not supported with vCenter Server 4.0

ESX MUI

No change

VMware Tools

Upgrade (optional)

ESX/ESXi 3.5 host

Upgrade to ESX/ESXi 4.1 (optional)

ESX/ESXi 4.0 host

Upgrade to ESX/ESXi 4.1 (optional)

ESX/ESXi 4.1

Install

VMFS3 volumes

No change

VM3 virtual machines

Upgrade to VM4 or VM7 (optional)

VMDK3 virtual disk

Not supported with vCenter Server 4.1