Some virtual machines that you create on ESX 4.0/ESXi 4.0 hosts are supported on ESX 3.x/ESXi 3.5 hosts.

If you create a virtual machine on ESX 4.0/ESXi 4.0 and select the typical path, the virtual hardware version is version 7. Virtual machines with virtual hardware version 7 are not supported on ESX 3.x/ESXi 3.5 hosts. When you create virtual machines on ESX 4.0/ESXi 4.0, select the custom path and select virtual hardware version 4 to ensure that your virtual machines can run on ESX 3.x/ESXi 3.5 hosts. When the virtual machines have virtual hardware version 4, you can migrate the virtual machines between the ESX 3.x/ESXi 3.5 and ESX 4.0/ESXi 4.0 hosts and use VMotion.

If you create virtual machines that use paravirtualization (VMI) or an enhanced networking device (vmxnet), VMotion is not supported. In this case, you can move the virtual machine to the ESX 3.x host if the virtual machine is powered off. Virtual machines that you create on ESX 4.0/ESXi 4.0 hosts are not supported on ESX 2.x hosts.