View Composer requires an SQL database to store data. The View Composer database must reside on, or be available to, the View Composer server host.

If a database server already exists for vCenter Server, View Composer can use that existing database server if it is a version listed in Supported Database Servers for View Composer. For example, View Composer can use the Microsoft SQL Server 2005 or 2008 Express instance provided with vCenter Server. If a database server does not already exist, you must install one.

View Composer supports a subset of the database servers that vCenter Server supports. If you are already using vCenter Server with a database server that is not supported by View Composer, continue to use that database server for vCenter Server and install a separate database server to use for View Composer and View Manager database events.

Important

If you create the View Composer database on the same SQL Server instance as vCenter Server, do not overwrite the vCenter Server database.

Supported Database Servers for View Composer lists the supported database servers and versions. For a complete list of database versions supported with vCenter Server, see the VMware vSphere Compatibility Matrixes on the VMware vSphere documentation Web site.

Supported Database Servers for View Composer

Database

vCenter Server 5.0 U1 and later

vCenter Server 4.1 U2 and later

vCenter Server 4.0 U4 and later

Microsoft SQL Server 2005 (SP4), Standard, Enterprise, and Datacenter

(32- and 64-bit)

Yes

Yes

Yes

Microsoft SQL Server 2008 Express (R2)

(64-bit)

Yes

No

No

Microsoft SQL Server 2008 (SP2), Standard, Enterprise, and Datacenter

(32- and 64-bit)

Yes

Yes

Yes

Microsoft SQL Server 2008 (R2), Standard and Enterprise

(32- and 64-bit)

Yes

Yes

Yes

Oracle 10g Release 2, Standard, Standard ONE, and Enterprise [10.2.0.4]

(32- and 64-bit)

Yes

Yes

Yes

Oracle 11g Release 2, Standard, Standard ONE, and Enterprise [11.2.0.1]

with Patch 5

(32- and 64-bit)

Yes

Yes

Yes

Note

If you use an Oracle 11g R2 database, you must install Oracle 11.2.0.1 Patch 5. This patch requirement applies to both 32-bit and 64-bit versions.