Supported Configurations and System Requirements

Revised November 13, 2013.

The supported platforms tables list each VMware® vFabric Suite™ component in the left-most column, and then operating systems and JVMs that the component supports. A Yes value means that you can install the component on a VM configured with the indicated operating system; a No value means that installing the component on the operating system is not supported. vFabric Suite and VMware Product Support lists VMware products that support vFabric Suite.

Note

VMware supports only those operating system versions that are still supported by the OS vendor and that have not been designated end-of-life (EOL). For example, the inclusion of RedHat Enterprise Linux (RHEL) 5 in the following tables means that VMware supports vFabric Suite products with RHEL 5.x versions that are currently available and supported under RedHat's policies.

Subtopics

Production-Supported Platforms for vFabric Suite

Development-Supported Platforms for vFabric Suite

vFabric License Server Support

Database Systems Supported by vFabric License Server

vFabric Suite and VMware Product Support

VMware Support for Open Source Software Used with vFabric Suite

Production-Supported Platforms for vFabric Suite

The next table shows production-supported platforms and configurations for vFabric Suite Standard and vFabric Suite Advanced.

Note

Some standalone vFabric Suite components support additional configurations and have additional requirements. To display this information, click on the component name in the following table.

Table 1. Production-Supported Platforms for vFabric Suite

vFabric Suite ComponentRedHat Enterprise Linux (RHEL) 5 x86 (32 bit)RedHat Enterprise Linux (RHEL) 5 x86 (64 bit)RedHat Enterprise Linux (RHEL) 6 x86 (64 bit)Microsoft Windows 2008 Server x86 (64 bit)CentOS 5 x86 (64 bit)CentOS 6 x86 (64 bit)Oracle Java SE 61Oracle Java SE 7
vFabric License ServerNoNoYesYesNoYesYesYes (Windows version only)
vFabric tc Server 2.9 (Spring Edition)YesYesYesYesYesYesYesYes
vFabric EM4J 1.3YesYesYesNoNoNoYesYes
vFabric EM4J 1.3 Console Guest Collector (CGC)YesYesYesNoYesYesYesYes
Spring Insight Operations 1.9YesYesYesYesYesYesYesYes
vFabric Hyperic 5.0 Agent/ServerYes/NoYes/YesYes/YesYes/YesNo/NoNo/NoYes/YesNo/No
vFabric GemFire 7.0 (Application Cache Node)YesYesYesYesYesYesYesYes
vFabric SQLFire 1.1 (Professional)YesYesYesYesYesYesYesYes
vFabric RabbitMQ 3.0YesYesYesYesYesYesN/AN/A
vFabric Web Server 5.3YesYesYesYesYesYesN/AN/A
vFabric Postgres 9.3 (Standard Edition) Agent/ServerYes/NoYes/YesYes/YesYes/NoYes/NoYes/NoYes/N/AYes/ N/A
vFabric Application Director 5.0 (Provisioning)N/AN/AN/AN/AN/AN/AN/AN/A

1Java 6 EOL (Feb 2013).

Development-Supported Platforms for vFabric Suite

Many developers use consumer-focused operating systems that are not certified for production use, and most vFabric products function well on popular consumer operating systems. The developer support designation is intended to convey which products are "known to work" and that VMware will provide best-effort support for resolving reported issues that are discovered. Developer Support certifications are not supported for use in production.

The next table shows developer-supported platforms and configurations for vFabric Suite Standard and Advanced.

Note

Some standalone vFabric Suite components support additional configurations and have additional requirements. To display this information, click on the component name in the table.

Table 2. Development-Supported Platforms for vFabric Suite

vFabric Suite ComponentUbuntu 10.04 LTS x86 (64 bit)1Ubuntu 12.04 LTS x86 (64 bit)1Mac OS X 10.7 and laterMicrosoft Windows 7, 8 x86 (64 bit)Oracle Java SE 61Oracle Java SE 7
vFabric tc Server 2.9 (Spring Edition)YesYesYesYesYesYes
vFabric EM4J 1.3NoNoNoNoYesYes
vFabric EM4J CGCNoNoNoNoYesYes
Spring Insight Operations 1.9YesYesYesYesYesYes
vFabric Hyperic 5.0 Agent/ServerNo/NoNo/NoNo/NoNo/NoYes/YesNo/No
vFabric GemFire 7.0 (Application Cache Node)NoNoYesYesYesYes
vFabric SQLFire 1.1 (Professional)NoNoYesYesYesYes
vFabric RabbitMQ 3.01YesYesYesYesN/AN/A
vFabric Web Server 5.3YesYesNoYesN/AN/A
vFabric Postgres 9.3 (Standard Edition) Agent/ServerYes/YesYes/YesYes/YesYes/NoYes/N/AYes/N/A
vFabric Application Director 5.0 (Provisioning)N/AN/AN/AN/AN/AN/A

1Java SE 6 EOL (Feb 2013).

vFabric License Server Support

vFabric License Server is supported on versions 4.1, 5.0, and 5.1 of VMware® vCenter™. You can also install a version of vFabric License Server 5.3 in these non-vSphere environments:

Note

If you run vFabric Suite components on infrastructure other than what is described here, you must activate a local license for each component, rather than using the vFabric License Server.

To understand vFabric Suite licensing, see vFabric Licensing and Installing vFabric License Server and Activating Your License.

Database Systems Supported by vFabric License Server

vFabric License Server requires a database to store its license usage data.

The following two database systems are supported:

The specific versions of the supported databases are the same as those supported by vCenter Server.

For information about specific database versions and service pack configurations supported with vCenter Server, see the VMware Product Interoperability Matrixes and vCenter Server Database Patch and Configuration Requirements.

Note

A version of vFabric License Server runs on EC2 Amazon machine instances in a RHEL environment and on physical machines that are running RHEL. This License Server uses its own internal database.

vFabric Suite and VMware Product Support

vFabric Suite components, with the exception of EM4J and Application Director (see Note below), are supported on all currently supported versions of the following products:

Note

EM4J is supported on vSphere 5.0 and later. The EM4J plug-in for vSphere Web Client is supported on vSphere 5.0 and 5.1.

vFabric Application Director is supported only on vSphere 5.0 and vCloud Director 1.5 and later.

VMware Support for Open Source Software Used with vFabric Suite

In addition to VMware support for vFabric Suite commercial products, vFabric Suite licenses entitle you to VMware support for the following open-source software:

For details about what the support policy and supported versions, see these VMware Knowledge Base articles:

If your operating system is Red Hat Enterprise Linux (RHEL) 5 or 6, you can monitor the usage of the OSS components on your VMs. See Optionally Configure Computer to Track Open-Source Software Component Usage on RHEL.