Supported Configurations and System Requirements

Revised November 13, 2012.

The Production Support and Developer Support sections list each VMware® vFabric Suite™ Standard and vFabric Suite Advanced component in the left-most column, and then operating systems and JVMs that the component supports. A Yes value means that you can install the component on a VM configured with the indicated operating system; a No value means that installing the component on the operating system is not supported. vFabric Suite and VMware Product Support lists VMware products that support vFabric Suite.

Note

VMware supports only those operating system versions that are still supported by the OS vendor and that have not been designated end-of-life (EOL). For example, the inclusion of RedHat Enterprise Linux (RHEL) 5 in the following tables means that VMware supports vFabric Suite products with RHEL 5.x versions that are currently available and supported under Redhat's policies.

Subtopics

Production-Supported Platforms

Developer-Supported Platforms

vFabric Suite and VMware Product Support

Database Systems Supported by vFabric License Server

Production-Supported Platforms

The following table shows production-supported platforms and configurations for vFabric Suite Standard and vFabric Suite Advanced.

Note

Some standalone vFabric Suite components support additional configurations and have additional requirements. To display this information, click on the component name in the following table.

Table 1. Production-Supported Platforms for vFabric Suite

vFabric Suite ComponentRedHat Enterprise Linux (RHEL) 5 x86_32RedHat Enterprise Linux (RHEL) 5 x86_64RedHat Enterprise Linux (RHEL) 6 x86_64Microsoft Windows 2008 Server x86_32Microsoft Windows 2008 Server x86_64Oracle Java SE 6Oracle Java SE 7
vFabric tc Server 2.8YesYesYesYesYesYesYes
vFabric EM4J 1.2YesYesYesNoNoYesYes
Spring Insight Operations 1.8YesYesYesN/AYesYesNo
vFabric Hyperic 4.6YesYesYesYesYesYesNo
vFabric GemFire 6.6YesYesYesYesYesYesNo
vFabric SQLFire 1.0YesYesYesYesYesYesNo
vFabric RabbitMQ 2.8YesYesYesYesYesN/AN/A
vFabric Web Server 5.2YesYesYesYesYesN/AN/A
vFabric Postgres 9.1 Standard Edition Server/ClientNo/YesYes /YesYes /YesNo/ YesNo/ YesN/A YesN/A Yes
vFabric Administration Server 1.1YesYesYesYesYesYesYes
vFabric Application Director 1.0N/AN/AN/AN/AN/AN/AN/A
vFabric AppInsight 1.1 N/AN/AN/AN/AN/AYesNo
vFabric License Server 1.2N/AN/AN/AN/AYesN/AN/A

Developer-Supported Platforms

The following table shows developer-supported platforms and configurations for vFabric Suite Standard and Advanced.

Many developers use consumer-focused operating systems that are not certified for production use, and most vFabric products function well on popular consumer operating systems. The developer support designation is intended to convey which products are "known to work" and that VMware will provide best-effort support for resolving reported issues that are discovered. Developer Support certifications are not supported for use in production.

Note

Some standalone vFabric Suite components support additional configurations and have additional requirements. To display this information, click on the component name in the following table.

Table 2. Developer-Supported Platforms for vFabric Suite

vFabric Suite ComponentUbuntu 10.x x86_64 **Mac OS X 10.6+ x86_64Microsoft Windows XP x86_64Microsoft Windows 7 x86_64Oracle Java SE 6Oracle Java SE 7
vFabric tc Server 2.8YesYesYesYesYesYes
vFabric EM4J 1.2NoNoNoNoYesYes
Spring Insight Operations 1.8YesYesYesYesYesNo
vFabric Hyperic 4.6YesYesNoYesYesNo
vFabric GemFire 6.6YesNoYesYesYesNo
vFabric SQLFire 1.0YesNoYesYesYesNo
vFabric RabbitMQ 2.8YesYesYesYesN/AN/A
vFabric Web Server 5.2YesNoNoYesN/AN/A
vFabric Postgres 9.1 Standard Edition Server/ClientYes/YesNo/YesNo/YesNo/YesN/A YesN/A Yes
vFabric Administration Server 1.1YesYes for 10.7NoYesYesYes
vFabric Application Director 1.0N/AN/AN/AN/AN/AN/A
vFabric AppInsight 1.1N/AN/AN/AN/AYesNo
vFabric License Server 1.1N/AN/AN/AN/AN/AN/A

** Only stable, non-EOL releases supported.

vFabric Suite and VMware Product Support

vFabric License Server is supported on versions 4.1, 5.0, and 5.1 of VMware® vCenter™.

vFabric Suite components (such as vFabric tc Server and vFabric GemFire), with the exception of EM4J and Application Director (see Note below), are supported on all currently supported versions of the following products:

Note

EM4J is supported on vSphere 4.1, 5.0, and later. However, EM4J memory balloons are only active on vSphere 5.0 and later, and are deactivated on vSphere 4.1. The EM4J plug-in for vSphere Web Client is supported on vSphere 5.0 only.

vFabric Application Director is supported only on vSphere 5.0 and vCloud Director 1.5 and later.

Database Systems Supported by vFabric License Server

vFabric License Server requires a database to store its license usage data.

The following two database systems are supported:

The specific versions of the supported databases are the same as those supported by vCenter Server.

For information about specific database versions and service pack configurations supported with vCenter Server, see the VMware Product Interoperability Matrixes and vCenter Server Database Patch and Configuration Requirements.