Supported Configurations and System Requirements

Revised June 15, 2012.

This section describes the EM4J supported configurations and system requirements.

Subtopics

EM4J Agent Platform Support

Considerations and Limitations

EM4J 1.1 Agent Platform Support

The following table lists supported platforms for this release of EM4J.

Table 1. EM4J 1.1 Agent Platform Support

Operating SystemVersionArchitectureJVM
Red Hat Enterprise Linuxv5x86_32Java SE 6
Red Hat Enterprise Linuxv5x86_64Java SE 6
Red Hat Enterprise Linuxv5x86_64Java SE 7
Red Hat Enterprise Linuxv6x86_64Java SE 6
Red Hat Enterprise Linuxv6x86_64Java SE 7

EM4J is compatible with VMware ESXi 5.0 or greater. Virtual machines must be hardware level 7 or greater. A VM at hardware level 7 that is running EM4J can be migrated to ESXi 4.1 and back to ESXi 5.0, but EM4J ballooning is only supported when the VM is on an ESXi 5.0 or greater host.

The EM4J 1.1 agent is supported with the following Java workloads using a supported JVM:

  • vFabric tc Server 2.7

  • Apache Tomcat 6.0

  • Apache Tomcat 7.0

See also "Supported Configurations and System Requirements" for vFabric tc Server 2.7.