Supported Platforms

TCP/IPv6 is required on all platforms. Modern platforms have this support installed already. It is not necessary to configure IPv6 adapters; simply install the IPv6 socket support drivers and associated libraries. Vendor patch sets for compatibility with the current release of vendor Java are recommended for all vFabric Web Server installations, because the operating system flaws that affect sockets and multi-threaded services for Java similarly affect vFabric Web Server and its support libraries.

Table 1. vFabric Web Server 5.0 Supported Platforms

Operating SystemProcessorPackage Format
Red Hat Enterprise Linux (RHEL) 5x86 (32- and 64-bit)RPM and self-extracting ZIP (.zip.sfx)
Ubuntu 10.04x86 (64-bit)Self-extracting ZIP (.zip.sfx)
Windows 2003x86 (32-bit)Self-extracting ZIP (.zip.exe)
Windows 2008x86 (32- and 64-bit)Self-extracting ZIP (.zip.exe)