GFMon System Requirements

Verify that your system meets the installation and runtime requirements for GFMon.

GFMon is designed to run with full capabilities on platforms running Linux and Microsoft® Windows®.

Supported Platforms

This table lists the operating system and JDK/JRE combinations that GFMon supports. If you are interested in a platform that is not listed, please contact your VMware sales representative. VMware will evaluate whether it can support the platform, either as-is or under a special agreement, or whether there are reasons that prevent deploying on a particular platform.

Operating System Sun® JSE 1.6.0_17 Sun JSE 1.6.0_23
Red Hat® Enterprise Linux® 5 (patch 3), kernel version 2.6.18-128 EL, with GTK 2.10.4-20.el5 X
Windows XP 32-bit SP3 X
Windows XP 64-bit SP2 X
Microsoft Windows Server® 2003 SP2 X

These sections list the operating systems used for building and testing GFMon. GFMon may work with later system releases upon which it has not been tested.

Windows

GFMon has been tested successfully on:
  • Windows XP 32-bit SP3
  • Windows XP 64-bit SP2
  • Windows Server 2003 SP2

Linux

GFMon has been tested successfully on:
  • Red Hat Enterprise Linux 4 (patch 7), kernel version 2.6.9-78 EL
  • Red Hat Enterprise Linux 5 (patch 3), kernel version 2.6.18-128 EL
If you are not sure of the kernel version on your system, use this command to list it:
prompt> uname -r

Java Runtime Requirements

You must have a Java Runtime Environment (JRE) 1.5.0 or later for GFMon to run. GFMon does not include a bundled JRE or JDK so you can choose the version that best suits your unique system requirements. Note that the JDK/JREs versions listed in "Supported Platforms" above are the versions that were used during product testing. You can download the appropriate JDK or JRE from http://java.sun.com.

Runtime Requirements

GFMon has these additional runtime requirements:
  • Intel® 2 GHz Pentium® 4 (or equivalent) proessor
  • 1 GB RAM (recommended)
  • JMX admin agent running in GemFire 5.7 or higher

Other Software Requirements

You need Adobe Acrobat Reader for viewing the documentation distributed as PDF files. Download a free copy at http://www.adobe.com/products/acrobat/readstep.html.

You need a web browser to launch the documentation index page from the GFMon Help menu.