Because large enterprises must often perform phased upgrades, components are designed to be somewhat forward and backward compatible, at least during upgrades.

The following earlier versions of View components are supported for upgrading to Horizon 7:

Latest maintenance release of Horizon View 5.3

Latest maintenance release of VMware Horizon 6.0 (with View)

Latest maintenance release of VMware Horizon 6 version 6.1

Latest maintenance release of VMware Horizon 6 version 6.2

To determine the latest maintenance release of a particular component, see the Release Notes for that release, available from https://www.vmware.com/support/pubs/view_pubs.html

View Connection Server compatibility with Horizon Agents is limited to interoperability during a View Connection Server upgrade. You must upgrade View Agents or Horizon Agents as soon as possible to match the version of the View Connection Server that manages them.

The following table lists the components and show whether they are compatible with other components whose version is different.

Compatibility Matrix for VMware Horizon 7 and Earlier Versions of View Components

Connection Server: Earlier Version

Security Server: Earlier Version

View Composer: Earlier Version

View Agent: Earlier Version

Horizon Client (Windows): Earlier Version

Connection Server 7.0

Only during upgrade

Only if paired before upgrade

No

Only during upgrade

Yes

Security Server 7.0 (PCoIP and RDP)

No

N/A

No

Only during upgrade

Yes

View Composer 7.0

Only during upgrade

Only during upgrade

N/A

Only during upgrade

N/A

Horizon Agent 7.0

Only during upgrade (see the exception in the note following this table)

No

No

N/A

Only during upgrade

Horizon Client 4.0

Yes

Yes

Yes

Yes

N/A

Caution

During an upgrade, View Composer provisioning and maintenance operations are not supported. Operations such as provisioning and recomposing linked-clone desktops are not supported during the transitional period when any View servers are still running the earlier version. You can successfully perform these operations only when all instances of View Connection Server and View Composer have been upgraded to the latest version.

For details about which versions of View are compatible with which versions of vCenter Server and ESXi, see the VMware Product Interoperability Matrix at http://www.vmware.com/resources/compatibility/sim/interop_matrix.php.